Содержание

Обзор роутера Mirkotik RB750, начальная настройка

Предположим у вас есть некая нестандартная, по меркам общепринятых стандартов, сеть. Например, совершенно непонятным для окружающих способом, у вас завелось два провайдера интернет-доступа, а также целых три подсети. Все это не какая-то космическая ситуация, а вполне обыденное, можно даже сказать — домашнее дело. И как его «разрулить», причем в условиях строгой экономии — вопрос — по сложности постановки задачи, еще тот.

Я уже писал на блоге, что ранее консультировался с многими IT-специалистами, и в принципе ответ был один и тот же (с разными вариациями цен только) — тебе дорога к серверной стойке/коробке Cisco. Но опять же, вопрос состоял в том, — как обеспечить конфигурироание домашней сети, минимальными средствами, причем при лидирующем факторе минимального энергопотребления. Ведь данная разработка, вполне может быть использована на предприятии, либо же в условиях автономного энергоснабжения (солнечные батареи) где каждый киловатт — дорог. Уже сейчас в промышленности 1Кв/ч стоит около $0,15, что нисколько не радует.

 

Mikrotik RB750 коробка

Данная постановка задачи не нашла никакого решения, однако неожиданно на одном из технических форумов меня подтолкнули к покупке устройства под брендом Mikrotik. Именно этому устройству и будет посвящена данная статья.

Сразу скажу, данную «коробочку» я брал, как говориться, «самую простую», чтобы не было жаль потраченных средств, которые фактически очень тяжко вернуть, в случае поломки или же неверной эксплуатации устройства. Тем более покупал я это дело с помощью интернет-заказа, аж в Харькове. Ведь изделие, как оказалось, — достаточно редкое. Оно и не удивительно, ведь настройки зашкаливают обилием разнообразных понятий. Инсталляция такого роутер-борда, как еще называется  устройство, достаточно сложно. Оно и понятно, внутри целый «склад» всевозможных сетевых возможностей, иначе и не скажешь.

Итак, для начала, вот пару фото упаковки. Собственно она самая простая — картонная коробка, никаких дисков, даже нет пачкорда. В комплекте — только коробка, блок питания и устройство. Впрочем, на задней крышке коробки написана крайне важная информация:

Mikrotik RB750 надпись на коробке

Поэтому рекомендуется, внимательно изучать ваш комплект MIkrotik, если вы вдруг решитесь на такой подвиг, — купить и настроить данное устройство.

Вот так оно упаковано. Нет никакой лишней мишуры. Экономят как могут. Я такой подход всячески уважаю.

Открываем коробку

Вот все, что в коробке. Никаких дисков. ЕХЕ-шник, если надо — прямо в роутере, документация — в Интернете. Верно, не надо лишнего.

Комплектация

Задняя стенка Mikrotik Router Board 750 выглядит следующим образом:

Mikrotik RB750 задняя панель

Никаких опять излишеств, кнопок или чего-то еще, хотите перезапустить — идите в интерфейс или вытягивайте-вставляйте шнур. Сзади видны прорези для крепления, если кто захочет прикрепить устройство к какой-то коробке.

Mikrotik RB750 задняя панель

Вот так оно выглядит во включенном виде. Светодиоды сверху. Удобно, между прочим, когда системный блок сбоку-снизу, а устройство лежит сверху. Все видно сверху, что происходит.

Mikrotik RB750 подключено

Еще фото, вот так оно предварительно подключено, для начальной настройки. Конечно. в дальнейшем будет переключаться все много  раз.

Mikrotik RB750 Подключено, вид сзади

Собственно схема сети, которую хотелось бы получить в итоге:

Схема Сети 04/2012

 

На данный момент все это было реализовано, в несколько другом виде, разделенном на подсети по подключениям. Все «втыкнуто» в один свитч, и поэтому безопасность всего дела — равняется «минус единице». Вот и хотелось бы избежать данного дела. Ну и дополнительно желательно получить зелененький ШД плайер, доступный по вайфаю, чтобы провода не таскать. В дальнейшем, всю нижнюю сеть хочеться также перевести на беспроводку. Поскольку там ничего ценного нет, только фильмы, то ее можно так «открыть». Хотя там какое-то шифрование канала у вайфая есть.

Теперь пару слов про настройку. Для начала, сразу сообщу, если что-то настроили не так, перезагрузка происходит при нажатом микровыключателе Reset, нажать его непросто, берите зубочистку. Есть хитрость, — сброс происходит при выключении/включении питания, если нажать собственно указанный переключатель. При этом не надо его отпускать пока не начнет мигать светодиод ACT, который находиться тут же рядом, сзади. Вот на следующем фото, видно лучше:

Reset и ACT на задней крышке Mikrotik RB750

Подключение к Интернету происходит банально. 1-й интерфейс устройства подключаем к сетевому кабелю. В роутере там изначально  настроен исходящий DHCP клиент. На все остальные выводы роутера — подключен внутренний DHCP сервер соответственно. То есть — подключая к нему интерфейс, вы получаете рабочее соединение, в том случае если до этого пользовались DHCP. Конечно, все это верно в случае работы с один интерфейсом и парой компьютеров.

Однако данное устройство позволяет разрулить и более сложные ситуации. Для этого каждый интерфейс можно настроить отдельно. Например «повесить» на интерфейс №5 DHCP сервер с одним допустимым адресом. Такое полезно делать, когда вы имеете железное устройство, также настроенное для автоматического забора адреса и вам не хочеться, потом искать что и где находиться.

Кстати, при наличие группы адресов для DHCP, устройство почемуто начинает выдавать их с конца. То есть при наличие 192.168.5.10- 192.168.5.254 в первую очередь отдается 192.168.5.254. Это может сбить столку, если чесно, я был несколько удивлен, ведь нормально — отдавать адреса «с начала».

Итак, какова же последовательность действия для «подъема» свеого DHCP сервера, внутри роутер-борд 750?

Для начала следует указать, что интерфейс, который будет выдавать DHCP подключение, описан в списке сетей. Для того, чтобы это настроить надо зайти в веб-интерфейс, который изначально находиться (по крайней мере в этом устройстве) на 192.168.88.1. Конечно, данный адрес можно и даже нужно поменять, чтобы было какое-то подобие безопасности. Первоначально пользуйтесь admin без пароля, чтобы войти в админку, после первого же захода желательно поменять пароль (system — users — клик по имени).

Итак, для поднятия отдельного DHCP на 5-м выводе надо:

  • В пункте Interfaces изменить 5-й соответственно интерфейс, забрав у него признак «Master Port», то есть выставив его в «none»;
  • Тут же можно указать ограничение на выходящий трафик с этого интерфейса. Bandwidth TX. Совсем правда не понял, относительно чего он считается выходящим, вероятно относительно интерфейса роутера. Тогда это имеет смысл, конечно;
  • Устанавливаете тут же скорость в 100 Мб/с, данное устройство не дает 1Гб/с, хоть и показывает это в интерфейсе;
  • Далее надо , сохранившись, пойти в IP, и прописать новую подсеть, делается это в пункте IP/Adresses. Я указал подсеть 192.168.5.0/24 для 5-го интерфейса;
  • Далее в ip/DHCP server «поднимаем» собственно сервер, удобно пользоваться кнопкой DHCP Setup. Собственно, когда указываете промежуток адресов, обратите внимание, что он записывается отдельно в ip/pools. То есть если вы там что-то не так указали — можно потом откорректировать.

Собственно, после указания параметров, можно перезапустить DHCP сервер и подключить устройство, посмотреть как в Lease появиться выданный ему диапазон.

Несложно, если вы уже имели дело с DHCP, на самом деле. Просто есть тут пару нюансов, как видите, чтобы запустить это все дело в работу. Кстати, по давней привычке, после запуска DHCP, я перезагрузил роутер, System/Reboot. Аналогично поступил с NAS Synology DS212, который и включен к этому интерфейсу. На данный момент могу отметить, трафик практически не режется, 50-60Мб/в секунд проходят по второму интерфейсу спокойно. Это очень радует, ведь при сравнимых габаритах Dlink Dir 300 тким не может похвастаться.

Кстати,  роутер дает крайне наглядную статистику, прямо в настройках интерфейса.   Там же есть просмотр пакетов, пинг по маку, график загрузки, кароче — полный пакет утилит, чтобы проанализирвоать сеть. Вот пример, как идет трафик с ракспейс, точнее с Admin Cloud Servers, закачивается ФТП папочка весом в 5-6 гигабайт мелких файлов (по одному, тут можно посмотреть PHP скрипт для закачки).

Прохождение трафика

А вот так выглядит график загрузки интерфейса:

Загрузка сети — Interfaces

 

Пока я не настроил правда подключения к обеим провайдерам, хочу посмотреть на стабильность работы с «Киевстаром», ведь были неприятные ощущения от Длинк DLINK Dir-300,  он «резал» канал, обрывал связь, работал никудышно!

Далее буду искать способ управления каналами, пока он не очевиден, ведь возможностей в интерфейсе — крайне много. Я могу сказать, что половина названий пунктов меню мне просто не знакома. Хоть сетями я занимаюсь лет 15-ть. Однако даже «по-быстрому» настроенный роутер, решил пару проблем. А в случае полной настройки «грозит» закрыть вообще все вопросы.

В заключение хочеться только добавить что MikroTik делает и более продвинутые устройства, чем RB750, и с беспроводными модулями, и с гигабитными интерфейсами, конечно это все стоит дороже, но если вам надо объединить множество устройств в небольшой группе/офисе, попробуйте подходящий вам Router Board, это действительно профессиональное решение. А если учесть цену в $54 (для RB750), понимаешь, что и крайне дешевое.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

publikz.com

Настройка роутера Mikrotik RB750 для работы в малой сети

Как известно, маршрутизатор Промсвязь довольно плохо работает в режиме роутера. Периодически происходят зависания самого прибора. Почти полностью пропадает интернет в случае интенсивного пользования одним из пользователей. Решением этой проблемы может быть использование второго маршрутизатора для установления PPPoE соединения c провайдером.

В этой статье я опишу как можно настроить маршрутизатор Mikrotik RB 750 для совместной работы с ADSL модемом Промсвязь от ByFly и его аналогов для использования интернета, скажем, небольшой сетью на 8 компьтеров.

Настройка ADSL модема в бридж

Для тех кто хорошо разбирается в том как настравать сетевые карты и модемы в бридж переходим сразу к настройке PPPoE на Mikrotik. Соединяем 1-3 порт модема и сетевую карту компьютера патчкордом, идущим в комплекте. После чего запускаем команду ping 192.168.1.1 –t :

Если на модеме включён DHCP сервер, а IP адрес на сетевой карте автоматический вы должны увидеть такую картину:


Если вместо ответа выдаётся сообщение «Заданый узел недоступен» придётся проверить автоматический ли IP адрес стоит на вашем сетевом адаптере. Для этого щёлкаем в трее значёк компьютера, выбираем «Центр управления сетями и общим доступом«:

Выбираем «Изменение параметров адаптера» в открывшемся окне:

Делаем клик правой конопкой мыши на «Подключение по локальной сети» и выбираем «Свойства«:

В свойствах Протокола интернета версии 4 (TCP/IPv4) переставляем табуляторы в положение «Получить IP-адрес автоматически«, «Получить адрес DNS-сервера автоматически»:

Если и после этих манипуляций по команде ping 192.168.1.1 –t не начинают приходить ответные пакеты, нужно сбросить модем ресетом. Кнопка Reset обычно спрятана на «подошве» модема, дабы избежать случайных нажатий, плюс к этому она утоплена в корпус, и для того, чтобы ее нажать, нужно использовать какой-либо тонкий предмет (например, стержень шариковой ручки):

Эти же действия необходимо сделать, если вы забыли пароль от админки модема или хотите вернуть настройки модема на дефолтные.

После того, как команда ping 192.168.1.1 –t наконец начнёт выполняться, открываем ваш любимый обозреватель интернета и пишем в строке ввода: http://192.168.1.1. Пароль и логин по умолчанию в этом модеме admin. Нажимаем кнопочку «Отправить«:

Переходим на вкладку «Internet» ставим табулятор ISP на Bridge Mode:

Настройка маршрутизатора Mikrotik

Напомню что интернет на Mikrotik приходит по PPPoE c WAN порта. Соединим 1 порт Mikrotik с 1-3 портом модема Промсвязь сетевым кабелем и 2-5 порт Mikrotik с сетевой картой компьютера.

Приступим к настройке Mikrotik. Для начала получим IP адрес с маршрутизатора. По умолчанию вам присвоят IP адрес из диапазона сети 192.168.88.0/24. Откроем броузер и в строку ввода запишем http://192.168.88.1 нажмём ввод и попадём в так называемый WEBBOX – вебинтерфейс маршрутизатора:

Сразу же нажмём кнопочку Winbox, чтобы загрузить более удобный и быстрый GUI инструмент для работы c маршрутизатором. Сохраним на диск winbox.exe и из этой утилиты продолжим конфигурирование. Щёлкнем кнопку с точками, чтобы обнаружить доступные маршрутизаторы в этом широковещательном домене и выберем 192.168.88.1. Кстати, этот инструмент умеет работать с маршрутизатором, даже если адрес сетевой карты находится с устройством в разных подсетях. Для этого достаточно выбрать не IP адрес, а MAC адрес интерфейса маршрутизатора при обзоре доступных для конфигурирования роутеров. Нажимаем кнопочку «Сonnect«:

И, вуаля попадаем в консоль администрирования маршрутизатора. Перейдём в настройки DHCP Client и изменим основной маршрут mikrotik.

Щёлкаем дважды ether1-gateway и в появившемся окне снимаем галку «Add Default Route«, после чего перезагружаем роутер. Можно зайти IP/routes/ и удалить маршрут 0.0.0.0/0 через ether1-gateway вместо перезагрузки.

Настроим PPPoE соединение с интернетом. Выбираем interfaces/+/PPPoE Client:

Выбираем интерфейс через какой будет идти установление PPPoE «ether1-gateway» и пишем название получившегося соединения «ByFly«. Переходим на вкладку «Dial Out«.

В поле «User» пишем номер_договора@beltel.by, «Password» – пароль. Ставим галочку «Use Peer DNS«, что сконфигурирует встроенный DNS сервер микротика на использование серверов имён byfly для пересылки запросов.

Если всё правильно, напротив PPPoE интерфейса ByFly должна загореться буква R (сокращённое от Runing).

Настроим NAT, для этого перейдём на вкладку IP-Firewall-NAT.

Создадим плюсиком новое правило SCRNAT для интерфейса ByFly:

Переходим на вкладку «Action» и выбираем там «masquerade» после чего нажимаем OK:

Теперь на компьютере должен появиться интернет. Чтобы запретить нежелательные подключения к маршрутизатору из интернета следует изменить 3-е правило на вкладке Filter Rules ведь теперь внешим интерфейсом у нас служит не ether1-gateway, а ByFly:

Обновление версии Router OS на маршрутизаторе Mikrotik

Если что-то пошло не так или маршрутизатор плохо работает с провайдером первое, что нужно сделать, это обновиться до более новой версии Router OS. На данный момент версия 6.0 очень сырая и рекомендуем использовать v5.25 которая очень хорошо себя показала. Открываем Files и перетаскиваем на него скачанный с http://mikrotik.com файл прошивки.


После чего следует перезагрузить маршрутизатор:

Исочник http://netflow.by/blog/item/66-nastroika-marshrutizatora-mikrotik-dlya-raboty-v-maloy-seti

www.skleroznik.in.ua

Настройка Mikrotik RB750 на домашнего провайдера (PPPoE + IP TV multicast) / Mikrotik / SysAdmin Blog

Давно хочется мне поменять домашний D-Link DIR 320 на более производительную железку, т.к. он не справляется с 4 wi-fi устройствами и приставкой IP TV, не то что одновременно, а даже если пара девайсов работает. Да и больше 20 мегабит прокачать по wi-fi у меня не получилось его заставить работать. Попробовал DIR-615, но уж больно ПО у него сырое. Даже на официальном форуме подтвердили, IGMP Proxy пока не ждите, а хочется IP TV.
Наслышанный о устройствах Mikrotik решил протестировать и был приятно удивлен скоростью работы. Для опытов мне достался RB750. Скорость работы приятно удивила, не ожидал подобной прыти от девайса размером с пачку сигарет, а про количество функций я вообще молчу, можете почитать в интернете.
Итак, попробуем настроить доступ в интернет (домолинк в моем случае) и IP телевидение.

1. Доступ к настройкам.

Из коробки Mikrotik RB750 имеет IP адрес 192.168.88.1, логин admin без пароля. Ставим себе на сетевой карте 192.168.88.2 и заходим в браузере на адрес 192.168.88.1. Там скачиваем утилиту Winbox (в начале есть «Winbox is the graphical configuration application for RouterOS. Download it»), запускаем и коннектимся к 192.168.88.1.

Появится окно примерно такого вида:

2. Настройка доступа к провайдеру с авторизацией через PPPoE.

Жмем «PPP» и в появившемся окне красный плюс.


Добавляем PPPoE Client, в появившемся окне забиваем логин, пароль и выбираем интерфейс, к которому у нас подключен кабель провайдера.



Ждем внизу статус «connected». Если не появится, можно попроваботь нажать enable/disable, у меня почему-то повисало один раз на «waiting packet».

3. Настройка сетевого экрана.

Честно говоря с файрволом я возится не стал, времени было мало, поэтому я тупо отключил правило deny

4. Немного удобства

Для удобства можно переименовать интерфейсы в более удобоваримый вид, интернет в wan, а локальный интерфейс в lan.

Для этого два раза щелкните на интерфейс в списке «Interface list» и переименуйте его.

5. IP телевидение

Для активирования этой функции потребуется дополнительный модуль multicast, нужно скачать его с официального сайта, потом перетащить в раздел «Files», оттуда в раздел «System -> Packages». Главное, чтобы версия модуля и ОС совпадали. Если ОС старая, то придется ее обновить. Как это сделать в следующий раз. Итак, копируем модуль, перегружаем девайс и получаем активированный модуль:


Дальнейшие действия можно сделать и из winbox, но так как у меня был найденный в сети скрипт, я его залил через ssh. Для этого можно скачать программу putty, указать в ней адрес для подключения 192.168.88.1 и нажать «Open». Логин, пароль были в начале.

Откроется окно:


Через эту консоль можно сделать много всего интересного, но мы просто зальем скрипт:

routing igmp-proxy interface add interface=wan upstream=yes alternative-subnets=0.0.0.0/0
routing igmp-proxy interface add interface=lan upstream=no
ip firewall filter add action=accept chain=input dst-port=5000 protocol=udp
ip firewall filter add action=accept chain=input protocol=igmp

Скопируйте код в буфер и в консоли щелкните правой кнопкой для вставки.

Все, можно проверять ТВ.

В итоге железка показала себя очень хорошо. Скорость до 9о мегабит при 40 соединениях, процессор при этом 70%. Но мне такого девайса маловато, т.к. нет wi-fi, поэтому буду ждать модель RB/751-2n.

sysadminblog.ru

Обзор Mikrotik RB750UP и настройка автоматического перезапуска подключенных устройств.

Раньше для подключения устройств Mikrotik и Ubiquiti использовались отдельные блоки питания, что требовало наличия большого числа электрических розеток. При использовании БП с интегрированной сетевой вилкой оставались не использованные розетки – ведь воткнуть рядом 2 аналогичных блока было не возможно. Приходилось использовать дополнительные блоки розеток, или тройники, что вводило лишнюю точку отказа и создавало путаницу проводов. Теперь появился Mikrotik RB750UP – маршрутизатор со встроенным управляемым PoE инжектором. С его помощью можно запитать 4 устройства, поддерживающих пассивное PoE с напряжением 24 вольта.

Устройство найдет свое применение и в офисе, например для питания беспроводных маршрутизаторов, и в сетях беспроводных провайдеров, для питания многосекторных базовых станций.

 

Поставляется Mikrotik RB750UP в большой картонной коробке.

Внутри которой само устройство занимает лишь малую часть объема.

В комплекте поставки Mikrotik RB750UP идет большой и мощный блок питания в вместе с электрическим кабелем для подключения к розетке.

С задней стороны RB750UP располагается штекер для подключения блока питания, кнопка сброса, индикаторы активности и питания, а так же 5 сетевых портов 100 мегабит. Первый порт поддерживает питание PoE и отмечен синим цветом, 2-5 порты могут подавать электропитание на подключенные устройства, эти порты отмечены желтым.

В комплекте идет блок питания на 24 вольта, 2.5 ампера. Следовательно, при использовании всех 4-х портов на каждый, получается, по 500 миллиампер. Это около 12 ватт на устройство – маловато. Устройство может контролировать потребляемый ток и автоматически отключать порты из-за перегрузки или короткого замыкания. При этом остальные порты будут продолжать работать в обычном режиме.

Каждый, кто работает с сетевыми устройствами, сталкивался с ситуацией, когда исправно работающий роутер или маршрутизатор вдруг переставал отвечать на запросы, или иными словами – зависал. Вернуть устройство к жизни и нормальному функционированию можно только одним способом – выключить и включить его снова. Это легко сделать, когда оно подключено к сетевому фильтру, который лежит под столом системного администратора. Но как быть, если доступ к зависшему устройству ограничен? Такое бывает, если оно размещено на телекоммуникационной мачте, или в арендованном помещении. Зависания обычно происходят тогда, когда доступ к нему невозможно получить, а ожидание начала следующего дня происходит долго и утомительно – ведь сетевые сервисы не работают.

 

С помощью Mikrotik RB750UP можно управлять питанием подключенных устройств на расстоянии вручную, или с помощью автоматического опроса доступности подключенного оборудования.

Для проверки возможностей устройства к 5-му сетевому пору подключим Mikrotik RB751U-2HnD следующим образом:

 

После подключения нового устройства к сети первое, что нужно сделать — отменить начальную конфигурацию, потом обновить прошивку устройства, и только после этого приступать к настройке.

 

При доступе на устройство через winbox нужно зайти в раздел INTERFACES что бы ознакомиться с возможностями управления питанием. С виду вроде ничего не обычного нет и можно долго ломать голову, посещая различные пункты меню в поисках нужного переключателя.

А оказывается все на виду – достаточно зайти в свойства любого сетевого порта и обнаружить там выпадающий список в пункте, в котором и производится управление питанием — PoE Out, он может принимать следующие значения:

 

Auto – автоматическая подача питания. Устройство проверяет, поддерживает ли подключенное к порту устройство пассивное PoE или нет. И только при подключении соответствующего устройства включает подачу питания.

Off – подача питания отключена. По умолчанию стоит этот пункт.

On – подача питания всегда включена.

К порту Ether5 подключен маршрутизатор Mikrotik RB751U-2HnD и пока в пункте PoE Out не было изменено значение по умолчанию Off на Auto, сетевой порт был не активен. После подачи питания маршрутизатор включился и установилась связь между устройствами по сети, что и подтверждает буква R перед именем интерфейса.

Для решения поставленной задачи нужно создать новый бридж в разделе BRIDGE, нажав на + и далее ничего не меняя на Ok.

И на вкладке Ports добавить в него все 5 доступных сетевых портов. Добавлять можно только по одному, поэтому нажимаем 5 раз на + и в пункте Interface по очереди указываем порты с Ether1 по Ether5, а в пункте Bridge каждый раз одно и то же – Bridge1.

В разделе IP—+ADDRESS укажем адрес устройства. Нажав на + в открывшемся окне в пункте Address укажем 10.0.0.10/24 и укажем интерфейс Bridge1 в пункте Interface.

На устройстве Mikrotik RB751U-2HnD, подключенному к 5-му сетевому порту произведем настройку IP-адреса так же в разделе IP—+ADDRESS, укажем в пункте Address10.0.0.11/24 и в пункте Interface — Bridge1. Все сетевые порты при этом должны быть заранее объединены в бридж. Указанный адрес будет использоваться для проверки доступности устройства.

Проверку работоспособности можно осуществить с помощью пинга до него. Для этого на RB750UP в разделе TOOLS—+PING запускаем соответствующую утилиту. В пункте Ping To указываем адрес RB751U10.0.0.11 и нажимаем кнопку Start. Видно что пинги до устройства проходят – то есть все в порядке.

Если пинги вдруг прерываются – значит устройство перестало нормально функционировать. Доступа по сети на него нет – помочь может только перезагрузка или отключение питания.

Для отключения питания заходим в раздел INTERFACES, выбираем интерфейс Ether5 и в пункте PoE Out выбираем Off – то есть, отключаем питание на порту. Для отключения нужно нажать кнопку Ok или Apply.

Видно, что сетевой порт отключился, т.к. питание на подключенное устройство больше не подается.

Для возобновления подачи питания следует снова зайти в свойства интерфейса Ether5 и в пункте PoE Out сменить значение с Off на Auto или On.

Подключенное устройство вновь показало активность по сетевому порту.

И запуск проверки доступности устройства с помощью команды Ping подтверждает его работоспособность.

Но не всегда есть возможность вручную управлять питанием портов. Бывает, что сетевой администратор не может это сделать вследствие отсутствия на рабочем месте, либо если доступ к устройству прерывается из-за зависшего маршрутизатора, через который осуществляется связь с Mikrotik RB750UP.

 

Операционная система Mikrotik поддерживает создание скриптов для управления оборудованием и запуск их по расписанию. Для создания такого скрипта нужно знать IP-адрес проверяемого на доступность устройства, и имя интерфейса, к которому оно подключено.

 

Скрипт имеет следующий вид:

# LANMART.RU PoE Control Script;

:local PINGCOUNT 5;

:local PINGIP «10.0.0.11»;

:local POEINTERFACE «ether5»;

:log info message=»START PING TO $PINGIP»;

:local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];

:if ($PINGRESULT > 0) do={

:log info message=»PING TO $PINGIP OK»;

} else={

:log info message=»PINGTEST $POEINTERFACE POE OFF»;

/interface ethernet set $POEINTERFACE poe-out=off;

:delay 10;

:log info message=»PINGTEST $POEINTERFACE POE ON«;

/interface ethernet set $POEINTERFACE poe-out=auto;

:delay 10;

}

:log info message=»PING TO $PINGIP END»;

 

Где:

PINGCOUNT – количество отправляемых запросов для проверки доступности. Нужно устанавливать как минимум 5, что бы при случайных потерях не произошла не запланированная перезагрузка устройства.

PINGIP – сетевой адрес для проверки доступности. В нашем случае 10.0.0.11.

POEINTERFACE – сетевой интерфейс, к которому подключено контролируемое устройство. В нашем случае ether5. Указывать имя надо так, как назван интерфейс, большие и маленькие буквы считаются различными, и указав Ether5 ничего работать не будет.

Log info message – сообщения, которые добавляются в лог файл устройства, при выполнении скрипта.

Для создания скрипта следует зайти в раздел SYSTEM—+SCRIPTS, и нажав на + в открывшееся окно скопировать тело скрипта в текстовое поле Source. Имя скрипта в поле Name можно изменить на любое другое по желанию. Для сохранения данных следует нажать кнопку Ok.

Для запуска выполнения команд, с определенным интервалом, например раз в минуту, следует в разделе SYSTEM—+SHEDULER создать новое расписание, нажав на +. В открывшееся окне нужно указать имя расписанию в пункте Name, и в пункте Start Time выбрать вместо времени – Startup. Тогда при включении устройства сразу начнется отсчет времени на запуск этого расписания. В пункте Interval указывается интервал запуска, указываем там 00:01:00 – то есть запускать раз в минуту.

 

В текстовом поле On Event указываем команду запуска созданного ранее скрипта:

/system script run script1

Если вы при создании скрипта изменили имя – измените его и в этом примере. Нажмите кнопку Ok для сохранения изменений.

По прошествии некоторого времени в логах микротика можно будет наблюдать следующую картину – каждую минуту происходит запуск и выполнение скрипта, при этом он информирует, что подключенное устройство функционирует исправно.

Заходим на Mikrotik RB751U-2HnD и отключаем IP-адрес, нажатием на кнопку Х. Этим мы моделируем зависание подключенного устройства.

Через минуту происходит следующее:

В логе по времени 02:27:18 запускается скрипт проверки доступности, который определяет что заданный адрес не отвечает на запросы и отключает питание PoE по этому порту. О чем сигнализирует сообщение ether5 link down в логах.

По истечении 10 секунд питание снова подается, и устройство через 25 секунд загружается и вступает в работу, о чем снова сигнализирует сообщение ether5 link down, сразу после него появляется сообщение ether5 link up, что говорит об успешной загрузке подключенного к этому порту устройства.

Последние сообщения в логах сигнализирует о доступности устройства.

Но предварительно нужно быстро зайти на Mikrotik RB751U-2HnD и включить сетевой адрес нажатием на синюю галочку. Что бы скрипт проверки доступности смог получать ответы на команду Ping.

Для отключения запуска скрипта по расписанию, нужно отключить соответствующее правило. Понадобиться это может в том случае, когда к этому порту подключают другое устройство с другим адресом, что бы он постоянно не отключался.

Кроме утилиты winbox, управлять микротиком можно через WEB-интерфейс, который называется Webfig. Для доступа на него из внешней сети укажем дополнительный IP адрес – 192.168.0.123, на который сделан проброс портов с реального адреса Интернета.

Если теперь зайти через браузер по адресу 192.168.0.123 можно попасть на интерфейс управления, аналогичный winbox, но исполняемый в окне браузера. Доступ к нему можно получить даже с мобильного телефона из любого места, следовательно, управлять питанием подключенных устройств можно из любой точки мира – был бы лишь дешевый роуминг.

Для изменения параметров питания нужно так же зайти в свойства сетевого интерфейса Ether5 и в пункте PoE Out выбрать нужное значение, тем самым включить или выключить питание подключенного к порту устройства.

У сетевого порта Ether1 так же есть соответствующий пункт, однако изменение его состояния ни на что не влияет.

 

Аналогично с приведенной схемой управления питанием 5-го порта устройства, можно настроить управление всеми остальными. И сделать, например, проверку доступности устройств, подключенных по всем сетевым портам. Для этого нужно будет сделать 4 копии скрипта для управления каждым портом, соответственно изменив IP-адреса для проверки, запускать их на выполнение можно одним правилом планировщика, указав команды на последовательный запуск скриптов.

www.lanmart.ru

Настройка Mikrotik RB750 на домашнего провайдера (PPPoE + IP TV multicast)

Давно хочется мне поменять домашний D-Link DIR 320 на более производительную железку, т.к. он не справляется с 4 wi-fi устройствами и приставкой IP TV, не то что одновременно, а даже если пара девайсов работает. Да и больше 20 мегабит прокачать по wi-fi у меня не получилось его заставить работать. Попробовал DIR-615, но уж больно ПО у него сырое. Даже на официальном форуме подтвердили, IGMP Proxy пока не ждите, а хочется IP TV.

Наслышанный о устройствах Mikrotik решил протестировать и был приятно удивлен скоростью работы. Для опытов мне достался RB750. Скорость работы приятно удивила, не ожидал подобной прыти от девайса размером с пачку сигарет, а про количество функций я вообще молчу, можете почитать в интернете.
Итак, попробуем настроить доступ в интернет (домолинк в моем случае) и IP телевидение

1. Доступ к настройкам.
Из коробки Mikrotik RB750 имеет IP адрес 192.168.88.1, логин admin без пароля. Ставим себе на сетевой карте 192.168.88.2 и заходим в браузере на адрес 192.168.88.1. Там скачиваем утилиту Winbox (в начале есть «Winbox is the graphical configuration application for RouterOS. Download it»), запускаем и коннектимся к 192.168.88.1.
Появится окно примерно такого вида:

2. Настройка доступа к провайдеру с авторизацией через PPPoE. 
Жмем «PPP» и в появившемся окне красный плюс.

Добавляем PPPoE Client, в появившемся окне забиваем логин, пароль и выбираем интерфейс, к которому у нас подключен кабель провайдера.


Ждем внизу статус «connected». Если не появится, можно попроваботь нажать enable/disable, у меня почему-то повисало один раз на «waiting packet».

3. Настройка сетевого экрана.
Честно говоря с файрволом я возится не стал, времени было мало, поэтому я тупо отключил правило deny

4. Немного удобства
Для удобства можно переименовать интерфейсы в более удобоваримый вид, интернет в wan, а локальный интерфейс в lan.
Для этого два раза щелкните на интерфейс в списке «Interface list» и переименуйте его.

5. IP телевидение
Для активирования этой функции потребуется дополнительный модуль multicast, нужно скачать его с официального сайта, потом перетащить в раздел «Files», оттуда в раздел «System -> Packages». Главное, чтобы версия модуля и ОС совпадали. Если ОС старая, то придется ее обновить. Как это сделать в следующий раз. Итак, копируем модуль, перегружаем девайс и получаем активированный модуль:

Дальнейшие действия можно сделать и из winbox, но так как у меня был найденный в сети скрипт, я его залил через ssh. Для этого можно скачать программу putty, указать в ней адрес для подключения 192.168.88.1 и нажать «Open». Логин, пароль были в начале.
Откроется окно:

Через эту консоль можно сделать много всего интересного, но мы просто зальем скрипт:

routing igmp-proxy interface add interface=wan upstream=yes alternative-subnets=0.0.0.0/0
routing igmp-proxy interface add interface=lan upstream=no
ip firewall filter add action=accept chain=input dst-port=5000 protocol=udp
ip firewall filter add action=accept chain=input protocol=igmp

Скопируйте код в буфер и в консоли щелкните правой кнопкой для вставки.

Все, можно проверять ТВ.

В итоге железка показала себя очень хорошо. Скорость до 9о мегабит при 40 соединениях, процессор при этом 70%. Но мне такого девайса маловато, т.к. нет wi-fi, поэтому буду ждать модель RB/751-2n.

mikrotik-ubnt.blogspot.com

Базовая настройка роутера mikrotik

Продолжаю рассказ про замечательную серию устройств из Латвии, которые зарекомендовали себя как функциональные и надежные девайсы. В данной статье я подробно рассмотрю вопрос базовой настройки роутеров mikrotik на примере бюджетной и самой популярной модели RB951G-2HnD. Данная инструкция подойдет практически к любой модели, так как все они сделаны на базе одной и той же операционной системы.


Если у вас есть желание научиться работать с роутерами микротик и стать специалистом в этой области, рекомендую пройти курсы по программе, основанной на информации из официального курса MikroTik Certified Network Associate. Все подробности читайте ниже.

Введение

Роутеры Mikrotik routerboard достаточно давно появились на рынке, но так до сих пор и не завоевали большую популярность. Хотя свою нишу заняли. Лично я считаю, что это отличный роутер для дома, по надежности у него нет конкурентов. Это действительно маршрутизатор, который можно один раз настроить и забыть. Лично мне еще ни разу не попадалось устройство, которое бы приходилось принудительно перезагружать, чтобы вывести его из комы, как это часто бывает с другими бюджетными железками.

Распространение среди домашних пользователей сдерживает в первую очередь сложность настройки. И хотя более ли менее продвинутому пользователю может показаться, что ничего тут сложного нет. Но на самом деле есть. И я часто сталкивался с просьбами настроить роутер дома для раздачи интернета по wifi, так как купившие по чьей-нибудь рекомендации пользователи сами не могли полностью настроить нужный функционал, хотя инструкций в интернете хватает.

Этот пробел я хочу восполнить и написать подробную пошаговую инструкцию по настройке микротика с нуля для чайников на примере самой подходящей для дома модели RB951G-2HnD. У меня давно подготовлена личная шпаргалка в виде текстового файла. По ней я буквально за 10 минут настраиваю роутер и отдаю пользователю. То есть реально ничего сложного нет, если знаешь, что делаешь. На основе этой шпаргалки я и напишу материал.

Возможно опытному пользователю нечего будет тут почерпнуть, а может быть я сам что-то делаю не совсем правильно или не оптимально. Прошу сделать подсказку или замечание в комментарии, если это действительно так. Я пишу статьи в том числе и для того, чтобы самому научиться чему-то новому. Как гласит одна восточная мудрость — чтобы получить новые знания, нужно поделиться теми, что есть у тебя с другими. Именно этим я и занимаюсь на страницах данного сайта.

Описание Mikrotik RB951G-2HnD

Вот он, герой сегодняшней статьи — Mikrotik RB951G-2HnD. Его описание, отзывы и стоимость можно быстро проверить на Яндекс.Маркете. По количеству отзывов уже можно сделать вывод об определенной популярности этого роутера.

Внешний вид устройства.

Важной особенностью этого роутера, которой лично я активно пользуюсь, является возможность запитать его с помощью специального poe адаптера.

На изображении он справа. Берется стандартный блок питания от роутера и poe адаптер. Блок питания подключается к адаптеру, а от адаптера уже идет патч корд в первый порт routerboard. Маршрутизатор можно повесить на стену в любое место, нет необходимости привязываться к розетке. Сразу отмечу, что запитать роутер можно только poe адаптером микротика. У него другой стандарт и привычные poe свитчи 802.3af не подойдут.

Существует похожая модель RB951Ui-2HnD. Она отличается от описываемой мной только тем, что у нее 100Mb порт, а у RB951G-2HnD 1Gb. Если для вас эти отличия не принципиальны, то можете покупать более дешевую модель. В остальном они идентичны.

Будем потихонечку двигаться дальше. Как проще всего настроить микротик? Я для этого использую стандартную утилиту winbox. Можно пользоваться и web интерфейсом, но лично мне намного удобнее winbox. Так что для продолжения настройки скачивайте ее на компьютер.

Сброс настроек роутера

Подключаем роутер к сети, подаем питание и запускаем на компьютере winbox. Переходим на вкладку Neighbors и ждем, когда утилита найдет наш микротик. Это может занять какое-то время. На всякий случай можно нажать Refresh, если роутер долго не обнаруживается.

Нажимаем на мак адрес устройства, он должен будет скопироваться в поле Connect To. Пароль по-умолчанию для входа в роутеры mikrotik — пустой, а пользователь — admin. Вводим имя пользователя, поле с паролем оставляем не заполненным. Нажимаем connect. Нас встречает информационное окно, в котором приведено описание стандартных настроек.

Здесь их можно либо оставить, либо удалить. Я всегда удаляю, так как стандартные настройки чаще всего не подходят под конкретную ситуацию. Приведу несколько примеров, почему это так:

  1. Я запитал свой роутер по первому порту через poe адаптер и поэтому вынужден использовать этот порт как локальный. В настройках по-умолчанию этот порт используется как wan порт для получения интернета от провайдер.
  2. В настройках по-умолчанию установлено автоматическое получение настроек от провайдера по dhcp. Если у вас другой тип подключения, то вам стандартная настройка не подходит.
  3. По-умолчанию устанавливается адресное пространство 192.168.88.0/24. Мне лично не нравятся сетки по-умолчанию, так как если в них случайно воткнуть новое устройство, где будет так же забит умолчательный адрес, то в сети начнутся проблемы. Дома может это и не актуально, но в коммерческих организациях мне приходилось с этим сталкиваться. Поэтому я на всякий случай сетку всегда меняю.

Так что мы нажимаем Remove Configuration, чтобы удалить настройки. После этого роутер перезагрузится. Ждем примерно минуту и подключаемся к нему снова.

Если вы по какой-то причине не удалили сразу предустановки, то выполнить сброс настроек в mikrotik на заводские можно позже. Для этого надо в терминале набрать сначала system, а затем reset. У вас спросят подтверждение и после этого routerboard перезагрузится с заводскими настройками.

Обновление прошивки

После очистки настроек я рекомендую сразу выполнить обновление прошивки роутера Mikrotik. Для этого идем в раздел Download официального сайта и скачиваем нужный файл. В данном случае это платформа mipsbe, пакет для загрузки Main package. Загружаем его на компьютер и подключаемся к роутеру с помощью winbox. Выбираем слева раздел Files. Затем открываем рядом два окна — один с файлом прошивки, второй с winbox и перетаскиваем мышкой файл из папки в winbox в список файлов.

Дожидаемся окончания загрузки прошивки и перезагружаем микротик через раздел меню System -> Reboot. Прошивка обновится во время загрузки роутера. Подождать придется минуты 3. Поле этого снова подключаемся к устройству. После обновления прошивки, нужно обновить загрузчик. Делается это в пункте меню System — RouterBoard. Заходите туда, проверяете строки Current Firmware и Upgrade Firmware. Если они отличаются, то жмете кнопку Upgrade. Если одинаковые, то можно ничего не делать. Изменения вступят в силу после перезагрузки.

Проверить версию установленной прошивки можно в разделе System — Packages.

В моем случае версия прошивки — 6.43.4. В будущем, когда на роутере будет настроен интернет, обновляться можно автоматически в этом разделе, нажимая на Check For Updates.

Прошивку обновили, можно приступать к настройке.

Объединение портов в бридж

Одной из особенностей роутеров mikrotik routerboard является отсутствие предустановленных настроек портов. Объясняю на пальцах, что это такое. Покупая обычный бюджетный роутер, вы увидите подписи к портам. На одном из них обязательно будет написано WAN, на других либо ничего не будет написано, либо LAN. То есть у вас уже будет один порт настроен определенным образом для подключения интернета и остальные порты будут объединены в switch для удобства подключения оборудования.

В Mikrotik не так. Там все порты равнозначны и WAN портом может стать абсолютно любой, какой пожелаете. Так как я 1-й порт использую для подключения питания, в качестве WAN у меня будет выступать 5-й порт. А все остальные я объединю в единую сеть с помощью bridge и добавлю к ним wifi интерфейс. Для этого идем в раздел Bridge и создаем новый bridge1.

Настройки все оставляем дефолтные. У нас появился bridge1. Переходим на вкладку ports и жмем плюсик. Добавляем в brdige1 все порты, кроме WAN. В моем случае это 5-й порт.

Мы объединили все необходимые интерфейсы в бридж для организации единого пространства для всех подключенных устройств.

Настройка статического IP

До этого мы подключались к роутеру по МАК адресу. Сейчас можно ему назначить статический локальный ip адрес, по которому он будет доступен в сети. Для этого идем в раздел IP -> Addresses и жмем плюсик.

Указываете в разделе Address любую подсеть. Я выбрал 192.168.9.0. Соответственно микротику мы назначаем адрес  192.168.9.1/24. В качестве интерфейса выбираем bridge1. Поле Network можно не заполнять, оно заполнится автоматически. Теперь наш роутер доступен и по локальным интерфейсам, и по wifi (который еще предстоит настроить) по адресу 192.168.9.1.

Настройка интернета в микротик

Сейчас самое время подключиться к провайдеру и настроить интернет. Тут трудно охватить все возможные варианты подключения. Их может быть много. Я рассмотрю два самых популярных способа:

  1. Вы получаете настройки от провайдера автоматически по dhcp.
  2. Провайдер дал вам готовые настройки и вы их вводите вручную.

Как я уже писал ранее, для подключения к провайдеру мы будем использовать 5-й порт. Подключайте провод провайдера.

Для получения настроек по dhcp переходите в winbox в раздел IP -> DHCP Client и жмите плюсик. Выбираете интерфейс ether5 и жмете ОК.

Если вы все сделали правильно, то увидите, какой IP адрес получили. В разделе IP -> Addresses будет информация о настройках.

Рассмотрим вариант, когда провайдер выдал все настройки и вам нужно самим их задать. Будем считать, что наши настройки интернета следующие:

IP адрес192.168.1.104
Маска255.255.255.0
Шлюз192.168.1.1
DNS192.168.1.1

Сначала укажем IP адрес. Делаем все то же самое, что и в предыдущем пункте при настройке статического IP. Только теперь вместо интерфейса bridge1 указываем ether5 и вводим соответствующий адрес — 192.168.1.104/24. Тут мы сразу указали и адрес и маску подсети.

Дальше нам нужно установить шлюз по-умолчанию. Без этого обязательного шага интернет не заработает. Идем в раздел IP -> Routes и жмем плюсик для добавления шлюза по-умолчанию. В Dst. Address оставляем как есть 0.0.0.0/0, а в поле Gateway вписываем шлюз провайдера и жмем ОК.

Уже сейчас интернет должен заработать, но без указания DNS сервера обращаться можно только по прямым ip адресам. Например можно пропинговать ip адрес серверов гугла. Открываем New Terminal и проверяем.

Теперь установим DNS сервер. Для этого идем в IP -> DNS, в поле Servers вводим адрес dns сервера провайдера. Если у вас их два, то нажав на треугольничек, направленной вершиной вниз, вы можете ввести еще одно значение. Обязательно ставите галочку напротив Allow Remote Requests.

На этом все, мы полностью установили настройки интернета провайдера. Можно проверить и пропинговать привычный адрес сайта.

На самом маршрутизаторе уже есть выход в интернет. На нам нужно его настроить для пользователей. Для этого продолжаем настройку mikrotik.

Настройка dhcp сервера

Для того, чтобы подключенные устройства могли получать сетевые настройки автоматически с роутера, на нем необходимо настроить DHCP сервер. Делается это не сложно, я сейчас по шагам все распишу. Идем в IP -> DHCP, переходим на вкладку DHCP и нажимаем DHCP Setup. Нам предлагают выбрать интерфейс, на котором будет работать сервер. Выбираем bridge1.

Жмем next. Теперь нужно выбрать адресное пространство, из которого будут выдаваться ip адреса. По-умолчанию указана подсеть, в которую входит ip адрес роутера. На это подходит, оставляем значение по-умолчанию 192.168.9.0/24.

Дальше нужно указать адрес шлюза, который будут получать клиенты. Так как для них шлюзом будет выступать сам микротик, оставляем его адрес, который уже предложен.

Теперь нужно указать диапазон адресов, которые будут выдаваться клиентам. Если вам не принципиально и вы не знаете, зачем его нужно менять, то оставляйте как есть. Будут использованы все свободные адреса подсети.

На последнем этапе вводим адрес dns сервера, который будет выдаваться клиентам. Это может быть как сам микротик, так и dns сервер провайдера. Это не принципиально, но лучше указать сам роутер. Так что пишем туда локальный адрес 192.168.9.1.

Следующий параметр оставляем по-умолчанию и жмем Next. На этом настройка dhcp сервера для локальной сети закончена.

Если мы сейчас проводом подключим любого клиента к mikrotik, то он получит сетевые настройки, но в интернет выйти не сможет. Не хватает еще одной важной настройки — NAT.

Настройка NAT

NAT это преобразование, или как еще говорят трансляция сетевых адресов. Я не буду рассказывать, что это такое, можно самим почитать в интернете. Все современные роутеры имеют функцию NAT для обеспечения доступа к интернету абонентов. Так что мы тоже настроим NAT в mikrotik.

Идем в раздел IP -> Firewall, открываем вкладку NAT и жмем плюсик. На вкладке General указываем только один параметр Out. Interface — ether5 (интерфейс подключения к провайдеру), все остальное не трогаем.

Переходим на вкладку Action, выбираем в выпадающем списке masquerade. Остальное не трогаем и жмем ОК.

Все, NAT настроили. Теперь если подключить клиента проводом в один из портов, то он получит сетевые настройки по DHCP и будет иметь доступ к интернету. Нам осталось самая малость — настроить wifi для подключения беспроводных клиентов.

Настройка wifi точки доступа в mikrotik

Наш роутер почти готов к работе. Осталось только настроить wi fi точку доступа и можно про него забывать :). Настройка wifi в микротике заслуживает отдельной статьи. Там очень много нюансов и возможностей. Мы сейчас сделаем самую простую настройку, которая подойдет и полностью удовлетворит потребности домашнего wifi роутера. А для более глубоких познаний можно будет воспользоваться отдельным материалом на эту тему.

Первым делом активируем беспроводной интерфейс. По-умолчанию он выключен. Идем в раздел Wireless, выбираем wlan1 и жмем синюю галочку.

Интерфейс из серого станет светлым. Переходим на вкладку Security profiles, два раза жмем мышкой на строчку с профилем default. В поле Mode выбираем dynamic keys. Ставим галочки напротив WPA PSK и WPA2 PSK и aes ccm. В поля WPA Pre-Shared Key и WPA2 Pre-Shares Key вводим пароль от будущей беспроводной сети. Я рекомендую использовать длинный пароль (не меньше 12-ти символов) с цифрами и спецсимволами. Да, вводить не очень удобно, но после того, как я сам без проблем брутил хэши простых паролей, я убедился, что лучше поставить сложный пароль, если не хочешь, чтобы к твоему wifi кто-то подключался.

Сохраняем настройки. Возвращаемся на вкладку Interfaces и два раза жмем на wlan1, открываются настройки wifi интерфейса микротика. Переходим на вкладку Wireless. Выставляем настройки как у меня на скриншоте.

Обращаю внимание на следующие настройки:

  • SSID — имя вашей беспроводной сети. Пишите то, что хочется.
  • Frequency — частота, соответствующая одному из 12-ти каналов. Самое первое значение это первый канал и так далее. Тут рекомендуется выбрать тот канал, который в вашем конкретном случае менее всего занят другими точками доступа. Если вы не знаете что это за каналы и как их проверить, то не обращайте внимания, может выбрать любое значение из списка.

Сохраняете настройки, нажимая ОК. Все, wifi  точка доступа на mikrotik настроена, можно проверять. Запускаете любое устройство, ищете вашу сеть, вводите пароль доступа и проверяете интернет. Все должно работать.

На этом основная настройка микротика закончена, но я рекомендую выполнить еще несколько настроек для удобства и безопасности.

Смена пароля администратора по-умолчанию

Как я уже писал ранее, пароль администратора по-умолчанию в mikrotik не задан, он пустой. Имя пользователя — admin. Давайте установим свой пароль для ограничения доступа посторонних к настройкам. Для этого идем в раздел System -> Users. Выбираем единственного пользователя admin, жмем правой кнопкой мыши и выбираем самый последний пункт password.

В открывшемся окошке 2 раза вводим свой пароль и сохраняем его. Теперь, чтобы подключиться через winbox нужно будет указать не только пользователя admin, но и установленный пароль.

В свете последних взломов микротика, я настоятельно рекомендую не просто установить сложный пароль на административную учетную запись, а создать полностью новую, с именем пользователя отличным от admin. Для этого в списке пользователей, жмите плюсик и создавайте нового пользователя.

После этого, пользователя admin можно отключить.

Настройка времени

Я рекомендую устанавливать правильное время и включать его автоматическую синхронизацию. Это может пригодиться, если вам понадобится посмотреть какие-нибудь логи и сопоставить время. Если оно не будет установлено, то это трудно сделать. Так что настроим его. Идем в System -> Clock, устанавливаем вручную время, дату и часовой пояс.

Сделаем так, чтобы время автоматически обновлялось через интернет. Идем в раздел System -> SNTP Client. Ставим галочку Enabled, в поле с адресами серверов вводим 193.171.23.163 и 85.114.26.194. Жмем Apply и наблюдаем результат синхронизации.

Теперь часы роутера всегда будут иметь актуальное время.

На этом базовая настройка роутера mikrotik для домашнего пользования закончена. Можно устанавливать его на место и пользоваться.

Заключение

Я привел пример настройки микротика для домашнего пользователя в качестве замены другим популярным бюджетным роутерам. Для более сложной и осмысленной настройки можно воспользоваться моими статьями на эту тему:

  • Настройка firewall  — рекомендую для всех, кто чувствует в себе способность разобраться дальше и повысить безопасность своей сети. Это может быть полезно даже дома. Собственно, статья и написана на примере ситуации, которая ложилась у меня в квартире. С помощью фаервола я отсек паразитный траффик и избавил маршрутизатор от тормозов.
  • Запрет на доступ к сайтам — может быть актуально для тех, кто хочет, к примеру, ограничить доступ с компьютера ребенка к каким-то ресурсам в интернете.
  • Настройка двух каналов в интернет для резервирования — статья о том, как подключить двух провайдеров интернета и автоматически переключать доступ с одного на другого в случае проблем со связью у одного из них. Ситуация взята из реального примера загородного дома с двумя каналами в интернет.
  • Настройка бесшовного wifi роуминга — популярный материал на тему организации единой сети wifi, состоящей из множества точек доступа для покрытия большой площади. Это может быть актуально как домашним пользователям (загородный дом) так и корпоративным пользователям.
  • Настройка хранения логов на mikrotik — рассказ о том, как централизованно хранить логи с микротиков. Для дома это совершенно не актуально, а для корпоративного сектора, где важно хранить информацию о том, кто, куда и зачем.

Я заканчиваю свой рассказ. Буду рад любым замечания и комментариям на данную тему.

Видео

Онлайн курсы по Mikrotik

Если у вас есть желание научиться работать с роутерами микротик и стать специалистом в этой области, рекомендую пройти курсы по программе, основанной на информации из официального курса MikroTik Certified Network Associate. Помимо официальной программы, в курсах будут лабораторные работы, в которых вы на практике сможете проверить и закрепить полученные знания. Все подробности на сайте Курсы по ИТ. Стоимость обучения весьма демократична, хорошая возможность получить новые знания в актуальной на сегодняшний день предметной области.

Помогла статья? Есть возможность отблагодарить автора

serveradmin.ru

Настройка роутера Mikrotik: детальный мануал.

Оборудование Mikrotik пользуется заслуженной популярностью у профессиональных сетевых инженеров, благодаря редкому сочетанию богатой функциональности, стабильной работы и невысокой цены.
Однако что хорошо инженеру, то рядовому пользователю — если не смерть, то боль и страдания как минимум. Mikrotik — оборудование от гиков для гиков
, поэтому настраивать его значительно сложнее, чем продукты конкурентов. На этапе начальной настройки и «засыпается» большинство пользователей, решивших причаститься к Mikrotik.

Тем не менее, процесс хоть и нетривиален, но вполне осваиваем. Разберем небольшой пример на базе устройства .

Подготовка

1.
Для начала скачиваем WinBox
— утилиту для управления устройствами Mikrotik. Работать с ней значительно удобнее, чем через web-интерфейс, установки она не требует. Берем отсюда: http://www.mikrotik.com/download

2.
Включаем роутер, к 1-му порту подключаем кабель провайдера Интернет
, компьютер — в любой другой.

3.
Запускаем WinBox. В нижней секции во вкладке Neighbors
, даже при отсутствии соединения с роутером по IP, его будет видно по MAC-адресу:

Логин по умолчанию — admin, пароля нет. Выбираем наше устройство и жмем Connect.

4.
После входа в устройство, нам откроется окошко RouterOS Default Configuration. Удаляем конфигурацию по умолчанию
, нажав на Remove Configuration
:

Из админки нас выбросит, входим заново, как в п. 3.

Настройка сетевых интерфейсов в Mikrotik RB951Ui-2HnD

1.
Открываем Interfaces
, видим такую картину:

2.
По умолчанию все проводные сетевые интерфейсы в Mikrotik называются etherN
. Оперировать такими названиями неудобно, поэтому откроем интерфейс ether1
, к которому у нас подключен кабель провайдера, и переименуем его в WAN
. В принципе, делать это необязательно — название ни на что не влияет. Но зато сильно упрощает администрирование роутера в будущем.

3.
Поочередно открываем интерфейсы ether2 — ether5, переименовываем их в LAN1 — LAN4.
На интерфейсе LAN1 параметр Master Port оставляем в положении «none», а на интерфейсах LAN2 — LAN4 переключаем параметр Master Port в положение LAN1

:

Расшифруем то, что было сделано: по умолчанию в роутерах Mikrotik порты не объединены в коммутатор, т.е. не умеют общаться друг с другом. За работу коммутатора отвечает специальный аппаратный чип коммутации, который позволяет разгрузить CPU устройства от коммутации пакетов между портами свитча.
Однако работать он будет только в том случае, если будут назначены Master и Slave порты (что и было нами сделано).
Второй вариант создания свитча — программный — предусматривает объединение портов в Bridge. В этом случае коммутацией пакетов будет заниматься CPU, а скорость работы устройства будет существенно ниже максимально возможной, что особенно хорошо заметно на гигабитных портах.

4.
Заодно включим беспроводной интерфейс
. К его настройке мы вернемся позже:

5.
Присваиваем ему более понятное название:

6.
Создаем новый Bridge.
Для этого открываем пункт меню Bridge
и жмем +
:

7.
Присваеваем мосту название — LAN
(т.к. внутри этого моста будут «ходить» пакеты по контуру нашей локальной сети):

8.
Переходим во вкладку Ports
, жмем на +
, чтобы добавить порты в мост:

Из кластера портов LAN1 — LAN4 нам достаточно добавить в мост только LAN1, поскольку для LAN2 — LAN4 он уже является мастер-портом
(см. п. 3 данного раздела). Соответственно, параметр Interface
LAN1
, Bridge
LAN
. Повторяем такое же действие для интерфейса WLAN
:

9.
Таким образом получаем следующий список портов внутри моста LAN:

Настройка параметров TCP/IP на Mikrotik

1.
Присвоим роутеру IP-адрес
. В нашем примере это будет 10.20.30.254 с маской 255.255.255.0 (или /24; вообще запись /24 эквивалентна записи /255.255.255.0, RouterOS понимает оба варианта. Подробности бесклассовой адресации можно выяснить здесь: https://ru.wikipedia.org/wiki/Бесклассовая_адресация). Для этого в меню IP
-> Addresses
добавим новый адрес и присвоим его интерфейсу LAN
(ранее созданный мост):

2.
Присвоим внешнему интерфейсу роутера IP-адрес.
В данном примере мы рассматриваем сценарий, когда провайдер Интернет предоставляет нам прямой доступ в сеть с белым IP-адресом.
Для этого снова жмем на +
в меню IP
-> Addresses
, вводим выданный провайдером адрес и маску
, а в качестве интерфейса выбираем WAN
:

3.
Наш список адресов принял следующий вид:

4.
Указываем роутеру, какими DNS-серверами пользоваться ему самому через меню IP -> DNS
:

5.
Укажем шлюз провайдера Интернета
. Для этого создадим в меню IP
-> Routes
новый маршрут, нажав +
, присвоим параметр Dst. Address
0.0.0.0/0
, Gateway
выданный нам провайдером
:

Настройка DHCP на Mikrotik

1.
Пора настроить DHCP-сервер, который будет раздавать IP-адреса в локальной сети. Для этого открываем IP
-> DHCP Server
и нажимаем кнопку DHCP Setup
:

2.
Выбираем интерфейс
, на котором будут раздаваться IP-адреса. В нашем случае — LAN
(мы же хотим раздавать IP-адреса только внутри локальной сети?):

3.
Вводим адрес сети и ее маску:

4.
Вводим адрес шлюза сети, т.е. нашего роутера:

5.
Вводим пул адресов, которые роутер будет раздавать подключенным к сети устройствам:

6.
Вводим адреса DNS-серверов (на скриншоте — DNS-серверы Google):

7.
Вводим срок, на который устройствам выдаются адреса (в формате ДД:ЧЧ:ММ):

8.
И после очередного нажатия кнопки Next работа мастера настройки DHCP заканчивается:

Настройка NAT на Mikrotik

1. Настраиваем NAT.
В меню IP
-> Addresses
во вкладке NAT
жмем +.
Во вкладке General
параметр Chain
ставим в положение scrnat
, Out. Interface
— в WAN
:

2.
Переходим во вкладку Action
, и ставим параметр Action
в положение masquerade
:

Теперь у нас должен появиться доступ в Интернет:

Настройка Wi-Fi на Mikrotik

1. Теперь настроим Wi-Fi.
Напомним, что в п. 4-5 раздела «Настройка сетевых интерфейсов в Mikrotik RB951Ui-2HnD», мы уже включили беспроводной интерфейс и присвоили ему новое название.
Теперь открываем меню Wireless
, вкладку Security Profiles
, а в ней — профиль default
.
Отмечаем галочками:

Authentication Types
WPA2 PSK

Unicast Ciphers
и Group Ciphers
aes ccm
и tkip

В поле WPA2 Pre-Shared

phocs.ru

alexxlab

Отправить ответ

avatar
  Подписаться  
Уведомление о